RP155 RP255 RP355 RP500 RP1000



You can get the official released versions from digitech.com

There have been MAC users reporting that their drums are corrupted after updating to a new version,
this is usually only on the MAC. The unit would come up saying "PREDSP" and "UPLOAD".
I now have updaters for both Windows and MAC for fixing drum sample problems.
MAC RP155 RP255 RP355 Drums
Windows RP155 RP255 RP355 Drums

There is a bug when using X-Edit that can cause serious problems.
This bug is in every product since the RP250.
Manually switching to another preset after dragging a user preset to a new location
using X-Edit. The new preset may be unstable.

The X-Edit bug is fixed in the latest beta versions

Below are the updaters for RP155 RP255 RP355 RP500 RP1000
These versions may or may not be released by DigiTech, again use these at your own risk
The version numbers displayed on the RPs will indicate that it is a beta version and not an official version

The Updaters will perform a factory reset after they are done downloading

Other updater notes:

If you stop an update (power glitch, plug pulled, etc.) you should power cycle your unit before restarting the updater app
If you stop an update near the end (usually indicated by the display twirling around) you should also restart everything
but you should also make sure that you run the same updater, if you select a different version to download your unit
may will fail when it is power cycled. DON'T PANIC, you may be able to recover from this by forcing the unit into
an update mode. You do this by:
RP155,RP255: hold down the "edit up" and "preset up" while powering on
RP355: hold down the "edit up" and "A/B" while powering on
RP500: hold down the "Amp/Cab enable" and the "pedal board" while powering on
RP1000: hold down the "Amp/Cab enable" and the "pedal board" while powering on


beta versions: these have a fix for X-Edit drag and drop

Rp500vB98 - added looper, added bank naming, note that bank nameing may be taken back out, backup/restore will work with or without bank naming
Rp1000vB94 - added bank naming, note that bank nameing may be taken back out, backup/restore will work with or without bank naming

The RP500vB98 has too many problems and thus I took it off this site, sorry, I hope to get it fixed soon.
See the forum for newer beta releases

Rp500vA94
Rp1000vA91
Rp155vA34
Rp255vA36
Rp355vA60


Beta X-Edit
Here is the zip file for the Windows X-Edit beta version for RPn55, RP1000, RPn55 (5/1/09)
Unzip the X-Edit folder then execute out of that folder

Released versions

Rp500v14
Rp1000v10
Rp155v10
Rp255v10
Rp355v11



How to use the looper in the RP500
This is subject to change (these are beta versions)

The looper is accessed by pressing and holding down the bank/preset up foot switch.
The display will show "LOOPCLRD". At this point the bank/preset up and down foot switchs control the looper.
in stopped/erased mode, Bank Down will arm the looper, a record will start when a signal is detected
in the arm mode, Bank Down will force a record to start
in record mode, Bank Up will stop the recording and set the loop point
in record mode, Bank Down will stop the recording and set the loop point and start playing
in play mode, Bank Down will start/stop overdub
in play mode, Bank Up will stop playing
press and holding Bank Up will clear the loop memory
press and holding Bank Up longer will exit looper mode

How to use bank naming
This is subject to change or be taken out (these are beta versions)

1) From performance mode (normal up down, not editing) press the "EDIT UP" button to get to the expression row
2) turn the left most knob until you see "BANKNAME"
3) press the knob you will see the name of bank 1, the factory setting is all blanks thus you should see " 1"
4) turn the knob to the bank you want to rename
5) press the knob and the left most character will begin to blink, from here you can edit the name,
use the second knob to change to the next character position
6) when you are don editing, press the knob to go back to the "BANKNAME" display
7) you can exit by pressing the "EDIT UP" or "EDIT DOWN" buttons
Note that X-Edit will backup and restore the bank names.
Note that if you use 10 patch mode in the RP1000 then you will only use the first 10 bank names.




Below are the latest release notes

rp500

1.4 A94
fixed USB for slow MACs - usb host input endpoint timeout was set to be much longer, see USBMidi_Tx_byte()
fix for Vista default audio - starts up in 16 bit mode instead of 24 bit mode
fix for x-edit drag and drop
1.4h A95 fix for bad USB audio
DSP fix for amp filter/tone stability and pre volume
1.4 A96 first release with looper enabled
1.4 B97 fix for assignment list of links, looper and bank naming
1.4 B98 fix for 16/24 bits Windows/MAC, bank naming, 4/29/09
1.4 A98 fix for 16/24 bits Windows/MAC, 4/29/09
1.4 B98 fix for 16/24 bits Windows/MAC, bank naming, 4/29/09
1.4 A99 latest USB fixes from RPn55
1.4 A01 fixed bug 24177 - bank up/down not working after looper exit, 5/27/09
new dsp for gain fixes - rebuilt presets
fix for entering looper in pedalboard mode
1.4 A02 new defaults for amp models - should be the same as the original rp500
1.4 A03 fixed library - uses rp500's original values, 6/5/09
fixed bypass exit using bank up/down
looper displays are better, doesn't re-load preset on looper exit
1.4 A04 fixed tap tempo
1.4 B05 Beta version with bank naming




rp1000

Since v1.0
A61 took out some redundancies during a preset load
fixes for MIDI when audio is streaming
fixes for speaker compensation (waiting for Billy's final approval), see file SpeakerComp.txt
sped up stompbox loop switch (for faster preset loads)
Can only clear looper when stopped (only when using external footswitch)
Footswitches (stompbox) send msg's to GUI
Fix volume and volume pedal update on powerup.
A62 Fix volume pedal update on powerup. Turn off distortion in preset 5. Fix for nolink footswitch.
A63 Fix for roundoff error when changing delay divide ratio.
A64 Fix for audio glitch when bypassing mod, dly, or rvb.
Add amploop to tuner mode.
Pedalboard LED stays on in bypass mode.
Store led does not turn on when plugging or unplugging amp or stomp loop jacks.
A65 Fix for acoustic mode audio dropout. IO_Mute added to amp model.
A66 DSP was broken on A65 - No other changes.
A67 fix for x-edit drag and drop
fix for x-edit restore/preset load from file
(tone & fx library fix for always showing the 1st selection)
new dsp to fix USB record levels during bypass - rebuilt presets
fix for volume/exp pedal update when exiting bypass or tuner
fix for ext foot switch loop clear is now a press and hold
fix to quiet the amp/cab bypass switch
amp loop switch and jack are now active during tuner and bypass
stompbox loop switch and jack are now active during bypass
x-edit is sent jack sense and amp loop switch upon tuner exit
A68 fixed CS compressor's default attack=0 and level=70
fixed name when x-edit uses a '%' for one of the characters - note it is blank on the rp1000
wah min/max now updates the wah pedal (when the wah is on)
update to how the speaker compensation and target system are used - see file SpeakerComp.txt
A69 fix for tone controls setting the store LED
fix for Vista default audio - starts up in 16 bit mode instead of 24 bit mode
tweak to the whammy, pitch etc. - presets rebuilt
A70 tweak to the whammy, pitch etc. (rebuilt presets)
added delay multiplier to the link list
A71 fixed compressor settings in presets 25, 26, 27, 99
fixed display when X-Edit selects the delay's tempo division for an assignment link
A72 fixed tuner pedal
stompbox loop now switchs without ramping in/out mute
A73 qtr outputs target system is now bypassed when the external amp is used
fixed stompbox loop click - new dsp, rebuilt presets
fixed delay multiplier - wasn't being initialzed thus it failed from one preset to the next
A74 tech test includes a check for inverted switchs - the key test will show "KEY FAIL"
A75 fix for target system
fix for tuner pre-emphasis
input levels tweaked for main dsp and tuner dsp - rebuilt presets
added bulk dump on startup with "fx up" and "amp loop" pressed
A76 fixed USB for slow MACs - usb host input endpoint timeout was set to be much longer, see USBMidi_Tx_byte()
A77 new USB recording and playback levels - presets rebuilt
A78 DSP fix for some amps thumping (actually the cab was causing it)
fix for pop when changing from a preset using amp loop to a preset that doesn' use amp loop
A79 fix for no audio when switching presests quickly - rebuilt presets
A80 fixed 2 tap delay's dry path - dry path keeps it's stereo image
the 2 tap delay fix also affect these delays: digital, analog, mod, pong, tape, echoplex, lofi
ramp up after a preset change is back to 1ms (was 5ms in vA78,vA79)
A81 fixed delay time division - if the delay time is changed manually it will be used as the new norm
A82 fixed cabinet wasn't being selected right during a preset load
fixed pop when changing presests between one with and one without amp loop enabled and looper on
re-built presets
made v-switch default less sensitive
A83 speaker comp is now off when using the external amp loop
v-switch default is back to what it use to be
A84 fix for slow amp loop switch
A85 faster amp loop switch, encoder switch can now be used to select and store a preset
A86 target system is now bypassed whenever the amp loop return is used - rebuilt presets
A87 fix for target system bypass when a cabinet is used - new DSP, rebuilt presets
fix for foot switch LED flashing when linked to amp loop enable
A88 new DSP for USB - updated record / playback levels, rebuilt presets
fix for foot switch LED when linked to amp loop on/off
A89 set the target system to TubePowerAmp

Version 1.1
Version 1.2
tweaked tech test, didn't affect normal operation
A90 fix for keeping the foot switch LEDs on after power up
A91 fix for bad USB audio
A92 DSP fix for amp filter/tone stability and pre volume - only pre volume was done on this version
A93 DSP fix for amp filter/tone stability
1.2 B94 fix for 16/24 bits Windows/MAC, bank naming, 4/29/09
1.2 A95 latest USB fixes from RPn55
1.2 A96 fixed bug 24177 - bank up/down not working after looper exit, 5/26/09
1.3 Release to 1.3, 6/16/09
1.2 B96 Beta version with bank naming




rp155

Since v1.0
A19 fixed USB recording in stereo/mono
A20 usb can now record during bypass
fix for volume update when exiting bypass or tuner
wah min/max now updates the wah pedal (when the wah is on)
fixed name when x-edit uses a '%' for one of the characters - note it is blank on the rp1000
fix for Vista default audio - starts up in 16 bit mode instead of 24 bit mode
fixed volume update for all presets
A21 fixed USB for slow MACs - usb host input endpoint timeout was set to be much longer, see USBMidi_Tx_byte()
A22 fix for post volume level controlling looper output - new dsp, rebuilt presets
A23 fixed startup display when updating firmware in bank 15
A24 new DSP - fix for clipping speaker comp - presets rebuilt
A25 added TS808 stompbox
A26 fix for bad USB audio
A27 fix for updater display, fix for MAC restore when last preset not on #1
A28 fix for MAC restore when last preset not on #1
fix for modulation pre/post (MAC X-Edit)
A29 another fix for modulation pre/post (X-Edit)
A30 another fix for modulation pre/post (X-Edit)
A31 fixed mod FX in presets: 21, 22, 36, 38, 45
A32 rebuilt preset 43 and 46
A33 fix for 16/24 bits Windows/MAC
A34 fix for backup/restore from v1.0 to v1.1, 4/29/09
A35 fix for 16/24 bits Windows/MAC and the one bad Vista machine, 4/30/09
A36 fixed preset 46's pitch shift amount (-12), 5/1/09
A37 fix for 16/24 bits Windows/MAC and the one bad Vista machine, 5/1/09
A38 fix for USB audio on some computers, 5/4/09
1.1 released v1.1, 5/7/09
B38 beta: stopped loading the 1020 twice, enabled 30MHz cpu




rp255

Since v1.0
A27 fix for x-edit restore/preset load from file
one possible bug is usb is always recorded in stereo regardless of the mono/stereo mode (I think it's a feature)
usb can now record during bypass
fix for volume update when exiting bypass or tuner
wah min/max now updates the wah pedal (when the wah is on)
fixed name when x-edit uses a '%' for one of the characters - note it is blank on the rp1000
fix for Vista default audio - starts up in 16 bit mode instead of 24 bit mode
A28 fixed USB for slow MACs - usb host input endpoint timeout was set to be much longer, see USBMidi_Tx_byte()
A29 fix for post volume level controlling looper output - new dsp, rebuilt presets
A30 new DSP - fix for clipping speaker comp - presets rebuilt
A31 fix for bad USB audio
A32 fix for MAC restore when last preset not on #1
fix for modulation pre/post (MAC X-Edit)
A33 another fix for modulation pre/post (X-Edit)
A34 another fix for modulation pre/post (X-Edit)
A35 fix for 16/24 bits Windows/MAC
A36 fix for backup/restore from v1.0 to v1.1, 4/29/09
A37 fix for 16/24 bits Windows/MAC and the one bad Vista machine, 4/30/09
A38 fix for USB audio on some computers, 5/4/09
1.1 released v1.1, 5/7/09
B38 beta: stopped loading the 1020 twice, enabled 30MHz cpu




rp355

Since v1.1
A52 new dsp - fixs pitch mix, delay time added to link list
fix for X-Edit drag and drop
fix for x-edit restore/preset load from file
usb can now record during bypass
fix for volume update when exiting bypass or tuner
wah min/max now updates the wah pedal (when the wah is on)
fixed name when x-edit uses a '%' for one of the characters - note it is blank on the rp1000
fix for Vista default audio - starts up in 16 bit mode instead of 24 bit mode
switching amp channels A/B is now less clicky
A53 fixed USB for slow MACs - usb host input endpoint timeout was set to be much longer, see USBMidi_Tx_byte()
A54 fix for post volume level controlling looper output - new dsp, rebuilt presets
A55 fix for sending x-edit amp channel change when the tone library is used
A56 new DSP - fix for clipping speaker comp - presets rebuilt
fix for sending x-edit amp A/B
A57 fix for bad USB audio
A58 changed wah's full range namem from "FULL" to "FULRNG"
fix for MAC restore when last preset not on #1
A59 fix for 16/24 bits Windows/MAC
A60 fix for backup/restore from v1.1 to v1.2, 4/29/09
A61 fix for 16/24 bits Windows/MAC and the one bad Vista machine, 4/30/09
A62 fix for USB audio on some computers, 5/4/09
1.2 released v1.2, 5/7/09
A64 fix for LAL
1.3 released v1.3, 5/15/09
1.3 released v1.3 again, 5/15/09, took out some debug - only a problem when receiving a CC from USB MIDI which we never do
A65 fix for pop when entering LAL, 6/4/09
A66 fix for click when entering or exiting LAL, 6/5/09
A67 another fix for click when entering or exiting LAL, 6/8/09
1.4 released v1.4, 6/9/09
B67 beta: stopped loading the 1020 twice, enabled 30MHz cpu